Changing monospace font doesn't affect all messages

RESOLVED INVALID

Status

Thunderbird
Message Reader UI
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Nikolay Shopik, Unassigned)

Tracking

({regression})

regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
While I can actually change size in preference to anything it doesn't affect any plain emails or view source. I'm running Ubuntu 9.10 with Official Mozilla Thunderbird Linux package.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1
Are you sure this is not a duplicate ?
(Reporter)

Comment 2

8 years ago
I did try search by word monospace didin't find exactly dupes. From what I see in Firefox we have same font settings and they actually work, but Firefox is bundled with Ubuntu. Will give a try 3.1 tomorrow
(Reporter)

Comment 3

8 years ago
Did try on different Linux machine but same Ubuntu 9.10 installed and it works for me.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

8 years ago
While I can change font in settings it does apply to new message font and some messages in message pane, but other messages are still having "default font". I see this is on both Linux and Windows build.
For example all bugzilla mails still having "default font", I'll attach mail where font changes are effective.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2pre) Gecko/20100224 Lanikai/3.1b1pre
Status: RESOLVED → REOPENED
OS: Linux → All
Hardware: x86 → All
Resolution: WORKSFORME → ---
Summary: Can't change monospace font size → Changing monospace font doesn't affect all messages
(Reporter)

Comment 5

8 years ago
Created attachment 429525 [details]
mail where you can see monospace font changes
(Reporter)

Comment 6

8 years ago
Wayne, did you see this too?
WFM changing both font and font size for monospace and opening a NEW window. However, displaying a different message in an existing 3pane window continues to use the same font+size.  Are these the steps you are looking for?

windows Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.2pre) Gecko/20100224 Lanikai/3.1b1pre
(Reporter)

Comment 8

8 years ago
Hmm that strange, whatever I try to change font or size it doesn't affect any of my bugmails. Tried to open in new tab or restart tab still using "default font" with same results in safe mode.
I agree it doesn't change bugmail behavior.  I misunderstood comment 4 and had only tested your attached testcase
(Reporter)

Comment 10

8 years ago
This looks like more core problem, but I doubt about component it fit.
(Reporter)

Comment 11

8 years ago
2.0.0.23 doesn't have such problems
Keywords: regression
(Reporter)

Comment 12

8 years ago
Here comes regression window 2007-02-06 last working correctly, and this one 2007-02-09 failed. There no windows build on 7 and 8 February.

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-02-06+00%3A00%3A00&maxdate=2007-02-09+23%3A59%3A00&cvsroot=%2Fcvsroot
Status: REOPENED → NEW
(Reporter)

Updated

8 years ago
Component: Preferences → Message Reader UI
QA Contact: preferences → message-reader
(Reporter)

Comment 13

8 years ago
From what I see if charset other than ISO-8859-1, you will not able to see font changes, while message have Content-Type: text/plain; charset=ISO-8859-1; it will work correctly displaying fonts.
(Reporter)

Comment 14

8 years ago
Created attachment 429702 [details]
Message with charset=windows-1251
Hmm, sounds like you need to change it for other encodings in the font chooser.
(Reporter)

Comment 16

8 years ago
Now I found it UTF-8 actually hides in other languages. Looks like TB2 behavior completely confuse me, anyway closing.
Thanks
Status: NEW → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
Yeah, I really don't like calling UTF-8 "other languages", because it's what's used a lot of the time. Oh well.
You need to log in before you can comment on or make changes to this bug.